summaryrefslogtreecommitdiff
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
authorPreston Gurd <preston.gurd@intel.com>2013-01-08 18:27:24 +0000
committerPreston Gurd <preston.gurd@intel.com>2013-01-08 18:27:24 +0000
commitc7b902e7fe3498503efbfd98cabb1b1c67cadda6 (patch)
tree7b93b61349d55c8f4a07b0d4392c070c9816d9ab /lib/Target/X86/CMakeLists.txt
parent2a92c10dcb1672750d51412534a6136552f415b0 (diff)
downloadllvm-c7b902e7fe3498503efbfd98cabb1b1c67cadda6.tar.gz
llvm-c7b902e7fe3498503efbfd98cabb1b1c67cadda6.tar.bz2
llvm-c7b902e7fe3498503efbfd98cabb1b1c67cadda6.tar.xz
Pad Short Functions for Intel Atom
The current Intel Atom microarchitecture has a feature whereby when a function returns early then it is slightly faster to execute a sequence of NOP instructions to wait until the return address is ready, as opposed to simply stalling on the ret instruction until the return address is ready. When compiling for X86 Atom only, this patch will run a pass, called "X86PadShortFunction" which will add NOP instructions where less than four cycles elapse between function entry and return. It includes tests. This patch has been updated to address Nadav's review comments - Optimize only at >= O1 and don't do optimization if -Os is set - Stores MachineBasicBlock* instead of BBNum - Uses DenseMap instead of std::map - Fixes placement of braces Patch by Andy Zhang. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@171879 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index 95f1f22e04..d14899d28a 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -25,6 +25,7 @@ set(sources
X86JITInfo.cpp
X86MCInstLower.cpp
X86MachineFunctionInfo.cpp
+ X86PadShortFunction.cpp
X86RegisterInfo.cpp
X86SelectionDAGInfo.cpp
X86Subtarget.cpp