summaryrefslogtreecommitdiff
path: root/lib/Transforms/Scalar/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2013-09-14 09:28:14 +0000
committerChandler Carruth <chandlerc@gmail.com>2013-09-14 09:28:14 +0000
commit3748de6e2d7620794ff93b896d85aff6cc0ea9d2 (patch)
tree5955ba7b6b32175c1c2e27b4df1ed625db00901e /lib/Transforms/Scalar/CMakeLists.txt
parentdcc425c6301c088b4c0598696de50c01fbca5733 (diff)
downloadllvm-3748de6e2d7620794ff93b896d85aff6cc0ea9d2.tar.gz
llvm-3748de6e2d7620794ff93b896d85aff6cc0ea9d2.tar.bz2
llvm-3748de6e2d7620794ff93b896d85aff6cc0ea9d2.tar.xz
Remove the long, long defunct IR block placement pass.
This pass was based on the previous (essentially unused) profiling infrastructure and the assumption that by ordering the basic blocks at the IR level in a particular way, the correct layout would happen in the end. This sometimes worked, and mostly didn't. It also was a really naive implementation of the classical paper that dates from when branch predictors were primarily directional and when loop structure wasn't commonly available. It also didn't factor into the equation non-fallthrough branches and other machine level details. Anyways, for all of these reasons and more, I wrote MachineBlockPlacement, which completely supercedes this pass. It both uses modern profile information infrastructure, and actually works. =] git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@190748 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Transforms/Scalar/CMakeLists.txt')
-rw-r--r--lib/Transforms/Scalar/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/Transforms/Scalar/CMakeLists.txt b/lib/Transforms/Scalar/CMakeLists.txt
index 7fa7807990..3b89fd4cfd 100644
--- a/lib/Transforms/Scalar/CMakeLists.txt
+++ b/lib/Transforms/Scalar/CMakeLists.txt
@@ -1,6 +1,5 @@
add_llvm_library(LLVMScalarOpts
ADCE.cpp
- BasicBlockPlacement.cpp
CodeGenPrepare.cpp
ConstantProp.cpp
CorrelatedValuePropagation.cpp