summaryrefslogtreecommitdiff
path: root/lib/Transforms/Scalar/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-09-22 01:08:49 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-09-22 01:08:49 +0000
commit3d01fc7de86c75926e4e5ac7cc49f0116018893d (patch)
tree2ea49e2f904dd479a4b941454b776dee762921dd /lib/Transforms/Scalar/CMakeLists.txt
parentcd4c73aa708d9ecf5d7e0a711dbf359d22b6dd3a (diff)
downloadllvm-3d01fc7de86c75926e4e5ac7cc49f0116018893d.tar.gz
llvm-3d01fc7de86c75926e4e5ac7cc49f0116018893d.tar.bz2
llvm-3d01fc7de86c75926e4e5ac7cc49f0116018893d.tar.xz
Initial support for the CMake build system.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@56419 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Transforms/Scalar/CMakeLists.txt')
-rw-r--r--lib/Transforms/Scalar/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/lib/Transforms/Scalar/CMakeLists.txt b/lib/Transforms/Scalar/CMakeLists.txt
new file mode 100644
index 0000000000..ff9193ac66
--- /dev/null
+++ b/lib/Transforms/Scalar/CMakeLists.txt
@@ -0,0 +1,32 @@
+add_llvm_library(LLVMScalarOpts
+ ADCE.cpp
+ BasicBlockPlacement.cpp
+ CodeGenPrepare.cpp
+ CondPropagate.cpp
+ ConstantProp.cpp
+ DCE.cpp
+ DeadStoreElimination.cpp
+ GVN.cpp
+ GVNPRE.cpp
+ IndVarSimplify.cpp
+ InstructionCombining.cpp
+ JumpThreading.cpp
+ LICM.cpp
+ LoopDeletion.cpp
+ LoopIndexSplit.cpp
+ LoopRotation.cpp
+ LoopStrengthReduce.cpp
+ LoopUnroll.cpp
+ LoopUnswitch.cpp
+ MemCpyOptimizer.cpp
+ PredicateSimplifier.cpp
+ Reassociate.cpp
+ Reg2Mem.cpp
+ SCCP.cpp
+ Scalar.cpp
+ ScalarReplAggregates.cpp
+ SimplifyCFGPass.cpp
+ SimplifyLibCalls.cpp
+ TailDuplication.cpp
+ TailRecursionElimination.cpp
+ )