summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Grosbach <grosbach@apple.com>2011-03-18 17:11:39 +0000
committerJim Grosbach <grosbach@apple.com>2011-03-18 17:11:39 +0000
commit1cb19a4470533be84eb61e8f5fc40aa9d45f86f9 (patch)
tree247a074ed1ba65138f012a7c59a804a00da3c648 /tools/CMakeLists.txt
parent5fd5b125ff41088c005b7107e8cf92f281313040 (diff)
downloadllvm-1cb19a4470533be84eb61e8f5fc40aa9d45f86f9.tar.gz
llvm-1cb19a4470533be84eb61e8f5fc40aa9d45f86f9.tar.bz2
llvm-1cb19a4470533be84eb61e8f5fc40aa9d45f86f9.tar.xz
MachO file loader and execution utility.
Add a bone-simple utility to load a MachO object into memory, look for a function (main) in it, and run that function directly. This will be used as a test and development platform for MC-JIT work regarding symbol resolution, dynamic lookup, etc.. Code by Daniel Dunbar. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@127885 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 2aceeb3272..c9072a7908 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -38,6 +38,7 @@ add_subdirectory(llvm-extract)
add_subdirectory(llvm-diff)
add_subdirectory(macho-dump)
add_subdirectory(llvm-objdump)
+add_subdirectory(llvm-rtdyld)
add_subdirectory(bugpoint)
add_subdirectory(bugpoint-passes)