summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-03-11 15:44:24 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-03-11 15:44:24 +0000
commit1dc550b383277f241f46a60628ae3f200769f13c (patch)
tree734de8034c51dbc1069fc42e8058551012e1fff9 /tools/CMakeLists.txt
parent2715a581494ef0c7f7403f9f7dbe4c0d052d61a5 (diff)
downloadllvm-1dc550b383277f241f46a60628ae3f200769f13c.tar.gz
llvm-1dc550b383277f241f46a60628ae3f200769f13c.tar.bz2
llvm-1dc550b383277f241f46a60628ae3f200769f13c.tar.xz
Add LTO and gold plugin to the CMake build. Linux-only, support for
other systems pending. PR9456. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@127466 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 2f37911d25..72364618b3 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -46,6 +46,14 @@ add_subdirectory(llvm-stub)
add_subdirectory(edis)
add_subdirectory(llvmc)
+if( LLVM_ENABLE_PIC )
+ # TODO: support other systems:
+ if( CMAKE_SYSTEM_NAME STREQUAL "Linux" )
+ add_subdirectory(lto)
+ add_subdirectory(gold)
+ endif()
+endif()
+
if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/clang/CMakeLists.txt )
add_subdirectory( ${CMAKE_CURRENT_SOURCE_DIR}/clang )
endif( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/clang/CMakeLists.txt )