summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2013-10-02 14:04:38 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2013-10-02 14:04:38 +0000
commit2be8ab460378455f82d719a872420fb5053f1bd5 (patch)
tree5c80de01001a50d2377895bc1ab25e1c99b7e5b6 /tools/CMakeLists.txt
parentc699417f11dce6d81f630d5b1c82e00dba852b37 (diff)
downloadllvm-2be8ab460378455f82d719a872420fb5053f1bd5.tar.gz
llvm-2be8ab460378455f82d719a872420fb5053f1bd5.tar.bz2
llvm-2be8ab460378455f82d719a872420fb5053f1bd5.tar.xz
Enable building LTO on WIN32.
Enable building the LTO library (.lib and.dll) and llvm-lto.exe on Windows with MSVC and Mingw as well as re-enabling the associated test. Patch by Greg Bedwell! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@191823 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 468d396b59..d8001e75a7 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -43,7 +43,7 @@ add_llvm_tool_subdirectory(llvm-symbolizer)
add_llvm_tool_subdirectory(obj2yaml)
add_llvm_tool_subdirectory(yaml2obj)
-if( NOT WIN32 )
+if( NOT CYGWIN )
add_llvm_tool_subdirectory(lto)
add_llvm_tool_subdirectory(llvm-lto)
else()