summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorArgyrios Kyrtzidis <akyrtzi@gmail.com>2013-08-27 23:27:56 +0000
committerArgyrios Kyrtzidis <akyrtzi@gmail.com>2013-08-27 23:27:56 +0000
commit587e1939fa1bd2bcce764c6dc53263f9faa44ab9 (patch)
tree334e6dfa303c28551208d6fe04c17bacc5d9daac /tools/CMakeLists.txt
parent22d6eb8ca91f4ce8db6a9ce8e2663502ebcee0c2 (diff)
downloadllvm-587e1939fa1bd2bcce764c6dc53263f9faa44ab9.tar.gz
llvm-587e1939fa1bd2bcce764c6dc53263f9faa44ab9.tar.bz2
llvm-587e1939fa1bd2bcce764c6dc53263f9faa44ab9.tar.xz
[CMake] Put back the add_llvm_external_project() calls for specific projects.
This allows setting-up the LLVM_EXTERNAL_* CMake variables that some people are using, e.g. to set the source directory of the project in a different place. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@189415 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 8a635a5b33..1f15fc0b64 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -64,6 +64,10 @@ endif()
add_llvm_external_project(clang)
if( NOT LLVM_INCLUDE_TOOLS STREQUAL "bootstrap-only" )
+ add_llvm_external_project(lld)
+ add_llvm_external_project(lldb)
+ add_llvm_external_project(polly)
+
# Automatically add remaining sub-directories containing a 'CMakeLists.txt'
# file as external projects.
add_llvm_implicit_external_projects()