summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Kramer <benny.kra@googlemail.com>2011-09-13 19:42:23 +0000
committerBenjamin Kramer <benny.kra@googlemail.com>2011-09-13 19:42:23 +0000
commit72c0d7fdd3d0930c7507060e96aec7d7429a8190 (patch)
tree78cea7afdfd25de5a88d35782530bc2e58049eb0 /tools/CMakeLists.txt
parent8c74f7f2991a10977fd5a003b2901b56eb2e19a8 (diff)
downloadllvm-72c0d7fdd3d0930c7507060e96aec7d7429a8190.tar.gz
llvm-72c0d7fdd3d0930c7507060e96aec7d7429a8190.tar.bz2
llvm-72c0d7fdd3d0930c7507060e96aec7d7429a8190.tar.xz
Sketch out a DWARF parser.
This introduces a new library to LLVM: libDebugInfo. It will provide debug information parsing to LLVM. Much of the design and some of the code is taken from the LLDB project. It also contains an llvm-dwarfdump tool that can dump the abbrevs and DIEs from an object file. It can be used to write tests for DWARF input and output easily. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@139627 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 8851a0b377..531b871512 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -39,6 +39,7 @@ add_subdirectory(llvm-diff)
add_subdirectory(macho-dump)
add_subdirectory(llvm-objdump)
add_subdirectory(llvm-rtdyld)
+add_subdirectory(llvm-dwarfdump)
add_subdirectory(bugpoint)
add_subdirectory(bugpoint-passes)