summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2011-11-03 17:30:16 +0000
committerDaniel Dunbar <daniel@zuster.org>2011-11-03 17:30:16 +0000
commit7fdd291c91eb89801bc6dd0ce998b9d3b0d92d10 (patch)
treefda507c2e1da831ff0b865b438f802634deb2079 /tools/CMakeLists.txt
parent98e0b9c86d1385d9cf04aef92651f0cdf8a46a9e (diff)
downloadllvm-7fdd291c91eb89801bc6dd0ce998b9d3b0d92d10.tar.gz
llvm-7fdd291c91eb89801bc6dd0ce998b9d3b0d92d10.tar.bz2
llvm-7fdd291c91eb89801bc6dd0ce998b9d3b0d92d10.tar.xz
llvm-config: Start stubbing out a C++ version of llvm-config (as llvm-config-2,
for now). - Mostly complete except for the data that needs to come from the build system or the dependencies. - Has some small improvements from current llvm-config: o Uses TargetRegistry directly to get some information. o Designed to work correctly when used from a CMake build tree (relatively untested currently) (although pcc fixed this recently for old llvm-config). git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@143616 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 49c73b718f..4269ae842b 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -19,6 +19,7 @@ if( NOT WIN32 OR MSYS OR CYGWIN )
add_subdirectory(llvm-config)
endif()
+add_subdirectory(llvm-config-2)
add_subdirectory(opt)
add_subdirectory(llvm-as)
add_subdirectory(llvm-dis)