summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2013-09-30 15:28:14 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2013-09-30 15:28:14 +0000
commita5b9cd1c68eda914ffcf133228824ca58e1ba518 (patch)
treefbfb2c9d295c5308bc92b9b665433fd8382366cd /tools/CMakeLists.txt
parent6ef4dd8cb6852fd0036244a07dc944dc8fb8933c (diff)
downloadllvm-a5b9cd1c68eda914ffcf133228824ca58e1ba518.tar.gz
llvm-a5b9cd1c68eda914ffcf133228824ca58e1ba518.tar.bz2
llvm-a5b9cd1c68eda914ffcf133228824ca58e1ba518.tar.xz
Enable building LTO on WIN32.
Enable building the LTO library (.lib and.dll) and llvm-lto.exe on Windows with MSVC and Mingw as well as re-enabling the associated test. Patch by Greg Bedwell! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@191670 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 468d396b59..d8001e75a7 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -43,7 +43,7 @@ add_llvm_tool_subdirectory(llvm-symbolizer)
add_llvm_tool_subdirectory(obj2yaml)
add_llvm_tool_subdirectory(yaml2obj)
-if( NOT WIN32 )
+if( NOT CYGWIN )
add_llvm_tool_subdirectory(lto)
add_llvm_tool_subdirectory(llvm-lto)
else()