summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2011-11-10 18:49:59 +0000
committerDaniel Dunbar <daniel@zuster.org>2011-11-10 18:49:59 +0000
commita6f5a81285bab84212209d47b1238505512c7c87 (patch)
tree91c13e119cf881c3a6527e1a9e7f0b149128c699 /tools/CMakeLists.txt
parentf084e1dc42c5c0a69c29de68bf129c39ca5d3641 (diff)
downloadllvm-a6f5a81285bab84212209d47b1238505512c7c87.tar.gz
llvm-a6f5a81285bab84212209d47b1238505512c7c87.tar.bz2
llvm-a6f5a81285bab84212209d47b1238505512c7c87.tar.xz
llvm-config: Replace with C++ version (was llvm-config-2).
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@144300 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 28b36dcdfd..46d08a4b17 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -11,16 +11,9 @@ if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
endif( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
if( NOT WIN32 OR MSYS OR CYGWIN )
- # It is useful to build llvm-config before the other tools, so we
- # have a fresh LibDeps.txt for regenerating the hard-coded library
- # dependencies. llvm-config/CMakeLists.txt takes care of this but we
- # must keep llvm-config as the first entry on the list of tools to
- # be built.
+ # We currently require 'sed' to build llvm-config, so don't try to build it on
+ # pure Win32.
add_subdirectory(llvm-config)
-
- # We currently require 'sed' to build llvm-config-2, so don't try to build it
- # on pure Win32.
- add_subdirectory(llvm-config-2)
endif()
add_subdirectory(opt)