summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Grosser <grosser@fim.uni-passau.de>2010-10-30 00:54:26 +0000
committerTobias Grosser <grosser@fim.uni-passau.de>2010-10-30 00:54:26 +0000
commitbaaadb2672e70916eb7e35b48b5ca34bec772fb8 (patch)
tree86cdaba77d5dcbba224ae9c59a2ad5f569f65a4d /tools/CMakeLists.txt
parent6b5252db2db5eeeadec4602329ac56beb6dea54a (diff)
downloadllvm-baaadb2672e70916eb7e35b48b5ca34bec772fb8.tar.gz
llvm-baaadb2672e70916eb7e35b48b5ca34bec772fb8.tar.bz2
llvm-baaadb2672e70916eb7e35b48b5ca34bec772fb8.tar.xz
Add polly support to the build system.
Update the cmake and autoconf build system to compile polly as a shared library if it is checked out into tools/polly. In case polly is not checked out, nothing changes. This models the way clang can be added to llvm if checked out to tools/clang. Also rebuild configure. Patch contributed by ether. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@117755 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 7ed10e9729..89d858c4e7 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -2,6 +2,14 @@
# large and three small executables. This is done to minimize memory load
# in parallel builds. Please retain this ordering.
+# If polly exists and is not disabled compile it and add it to the LLVM tools.
+option(LLVM_BUILD_POLLY "Compile polly" ON)
+if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
+ if (LLVM_BUILD_POLLY)
+ add_subdirectory( ${CMAKE_CURRENT_SOURCE_DIR}/polly)
+ endif (LLVM_BUILD_POLLY)
+endif( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
+
if( NOT WIN32 OR MSYS OR CYGWIN )
# It is useful to build llvm-config before the other tools, so we
# have a fresh LibDeps.txt for regenerating the hard-coded library