summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2013-03-17 12:01:05 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2013-03-17 12:01:05 +0000
commitdf41cf003aa8576a75a7f4e0a992a0a145167ee1 (patch)
treeb77441467d396fc8762445364fb437e3cb0f77a2 /tools/CMakeLists.txt
parenta98729b10ed664e8cf3aec7cfda31f052500d58f (diff)
downloadllvm-df41cf003aa8576a75a7f4e0a992a0a145167ee1.tar.gz
llvm-df41cf003aa8576a75a7f4e0a992a0a145167ee1.tar.bz2
llvm-df41cf003aa8576a75a7f4e0a992a0a145167ee1.tar.xz
Build LLVMgold.so on FreeBSD using cmake.
Patch by Stephen Checkoway. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@177233 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 4cf5aa5105..5e9560491e 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -49,7 +49,8 @@ endif()
if( LLVM_ENABLE_PIC )
# TODO: support other systems:
- if( CMAKE_SYSTEM_NAME STREQUAL "Linux" )
+ if( (CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ OR (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD") )
add_subdirectory(gold)
endif()
endif()