summaryrefslogtreecommitdiff
path: root/tools/gold/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-03-11 15:44:24 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-03-11 15:44:24 +0000
commit1dc550b383277f241f46a60628ae3f200769f13c (patch)
tree734de8034c51dbc1069fc42e8058551012e1fff9 /tools/gold/CMakeLists.txt
parent2715a581494ef0c7f7403f9f7dbe4c0d052d61a5 (diff)
downloadllvm-1dc550b383277f241f46a60628ae3f200769f13c.tar.gz
llvm-1dc550b383277f241f46a60628ae3f200769f13c.tar.bz2
llvm-1dc550b383277f241f46a60628ae3f200769f13c.tar.xz
Add LTO and gold plugin to the CMake build. Linux-only, support for
other systems pending. PR9456. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@127466 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/gold/CMakeLists.txt')
-rw-r--r--tools/gold/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tools/gold/CMakeLists.txt b/tools/gold/CMakeLists.txt
new file mode 100644
index 0000000000..ca3ce457d7
--- /dev/null
+++ b/tools/gold/CMakeLists.txt
@@ -0,0 +1,37 @@
+set(LLVM_BINUTILS_INCDIR "/usr/include" CACHE PATH
+ "PATH to binutils/include containing plugin-api.h for gold plugin.")
+
+if( NOT EXISTS "${LLVM_BINUTILS_INCDIR}/plugin-api.h" )
+ message(STATUS "plugin-api.h not found. gold plugin excluded from the build.")
+else()
+ include_directories( ${LLVM_BINUTILS_INCDIR} )
+
+ # Because off_t is used in the public API, the largefile parts are required for
+ # ABI compatibility.
+ add_definitions( -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 )
+
+ set(LLVM_LINK_COMPONENTS support)
+
+ add_llvm_loadable_module(LLVMgold
+ gold-plugin.cpp
+ )
+
+ # Makefile.rules contains a special cases for OpenBSD, Darwin and
+ # Windows. We restrict ourselves to Linux for the time being.
+ set(srcexp ${CMAKE_CURRENT_SOURCE_DIR}/gold.exports)
+ add_custom_command(OUTPUT exportsfile
+ COMMAND echo "{" > exportsfile
+ COMMAND grep -q "\\<" ${srcexp} && echo " global:" >> exportsfile || :
+ COMMAND sed -e "s/\$\$/;/" -e "s/^/ /" < ${srcexp} >> exportsfile
+ COMMAND echo " local: *;" >> exportsfile
+ COMMAND echo "};" >> exportsfile
+ DEPENDS ${srcexp}
+ VERBATIM
+ COMMENT "Creating export file for gold plugin")
+ add_custom_target(gold_exports DEPENDS exportsfile)
+ set_property(DIRECTORY APPEND
+ PROPERTY ADDITIONAL_MAKE_CLEAN_FILES exportsfile)
+
+ target_link_libraries(LLVMgold LTO -Wl,--version-script,exportsfile)
+ add_dependencies(LLVMgold gold_exports)
+endif()