summaryrefslogtreecommitdiff
path: root/tools/gold/CMakeLists.txt
diff options
context:
space:
mode:
authorNico Weber <nicolasweber@gmx.de>2013-12-28 23:31:44 +0000
committerNico Weber <nicolasweber@gmx.de>2013-12-28 23:31:44 +0000
commitb6fe25c47661a287224d09165b68ce76084294ca (patch)
treeb8f9b8e17241ebe4ea979afeda7ce16dea31afc3 /tools/gold/CMakeLists.txt
parent621bd8d76a698899959190849a1b21d019f56e52 (diff)
downloadllvm-b6fe25c47661a287224d09165b68ce76084294ca.tar.gz
llvm-b6fe25c47661a287224d09165b68ce76084294ca.tar.bz2
llvm-b6fe25c47661a287224d09165b68ce76084294ca.tar.xz
EXPORTED_SYMBOL_FILE support for cmake
The cmake build didn't support EXPORTED_SYMBOL_FILE. Instead, it had a Windows-only implementation in tools/lto/CMakeLists.txt, a linux-only implementation in tools/gold/CMakeLists.txt, and a darwin-only implementation in tools/clang/tools/libclang/CMakeLists.txt. This attempts to consolidate these one-offs into a single place. Clients can now just set LLVM_EXPORTED_SYMBOL_FILE and things (hopefully) Just Work, like in the make build. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@198136 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/gold/CMakeLists.txt')
-rw-r--r--tools/gold/CMakeLists.txt28
1 files changed, 2 insertions, 26 deletions
diff --git a/tools/gold/CMakeLists.txt b/tools/gold/CMakeLists.txt
index 2cc132ff78..e0a3359018 100644
--- a/tools/gold/CMakeLists.txt
+++ b/tools/gold/CMakeLists.txt
@@ -1,6 +1,8 @@
set(LLVM_BINUTILS_INCDIR "" CACHE PATH
"PATH to binutils/include containing plugin-api.h for gold plugin.")
+set(LLVM_EXPORTED_SYMBOL_FILE ${CMAKE_CURRENT_SOURCE_DIR}/gold.exports)
+
if( NOT LLVM_BINUTILS_INCDIR )
# Nothing to say.
elseif( NOT EXISTS "${LLVM_BINUTILS_INCDIR}/plugin-api.h" )
@@ -17,30 +19,4 @@ else()
add_llvm_loadable_module(LLVMgold
gold-plugin.cpp
)
-
- # Makefile.rules contains a special cases for OpenBSD, Darwin and
- # Windows. We restrict ourselves to Linux for the time being.
- set(srcexp ${CMAKE_CURRENT_SOURCE_DIR}/gold.exports)
- add_custom_command(OUTPUT exportsfile
- COMMAND echo "{" > exportsfile
- COMMAND grep -q "\\<" ${srcexp} && echo " global:" >> exportsfile || :
- COMMAND sed -e "s/$/;/" -e "s/^/ /" < ${srcexp} >> exportsfile
- COMMAND echo " local: *;" >> exportsfile
- COMMAND echo "};" >> exportsfile
- DEPENDS ${srcexp}
- VERBATIM
- COMMENT "Creating export file for gold plugin")
- add_custom_target(gold_exports DEPENDS exportsfile)
- set_property(DIRECTORY APPEND
- PROPERTY ADDITIONAL_MAKE_CLEAN_FILES exportsfile)
-
- # Force re-linking when the exports file changes. Actually, it
- # forces recompilation of gold-plugin.cpp. The LINK_DEPENDS target
- # property only works for makefile-based generators.
- set_property(SOURCE gold-plugin.cpp APPEND PROPERTY
- OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/exportsfile)
-
- target_link_libraries(LLVMgold LTO
- -Wl,--version-script,${CMAKE_CURRENT_BINARY_DIR}/exportsfile)
- add_dependencies(LLVMgold gold_exports)
endif()