summaryrefslogtreecommitdiff
path: root/tools/llc/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-09-22 01:08:49 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-09-22 01:08:49 +0000
commit3d01fc7de86c75926e4e5ac7cc49f0116018893d (patch)
tree2ea49e2f904dd479a4b941454b776dee762921dd /tools/llc/CMakeLists.txt
parentcd4c73aa708d9ecf5d7e0a711dbf359d22b6dd3a (diff)
downloadllvm-3d01fc7de86c75926e4e5ac7cc49f0116018893d.tar.gz
llvm-3d01fc7de86c75926e4e5ac7cc49f0116018893d.tar.bz2
llvm-3d01fc7de86c75926e4e5ac7cc49f0116018893d.tar.xz
Initial support for the CMake build system.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@56419 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llc/CMakeLists.txt')
-rw-r--r--tools/llc/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/llc/CMakeLists.txt b/tools/llc/CMakeLists.txt
new file mode 100644
index 0000000000..43f30be208
--- /dev/null
+++ b/tools/llc/CMakeLists.txt
@@ -0,0 +1,5 @@
+set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} bitreader asmprinter)
+
+add_llvm_tool(llc
+ llc.cpp
+ )