summaryrefslogtreecommitdiff
path: root/tools/llvm-ld/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2012-04-19 19:27:54 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2012-04-19 19:27:54 +0000
commit75338097c786eea1c461e744a2c45af78f56286f (patch)
treec76fcc9ba79df82b8fabeb896f0c6340629f8fdd /tools/llvm-ld/CMakeLists.txt
parentb423d18a00eed4968d6df7415449259b09b7d67e (diff)
downloadllvm-75338097c786eea1c461e744a2c45af78f56286f.tar.gz
llvm-75338097c786eea1c461e744a2c45af78f56286f.tar.bz2
llvm-75338097c786eea1c461e744a2c45af78f56286f.tar.xz
Remove llvm-ld and llvm-stub (which is only used by llvm-ld).
llvm-ld is no longer useful and causes confusion and so it is being removed. * Does not work very well on Windows because it must call a gcc like driver to assemble and link. * Has lots of hard coded paths which are wrong on many systems. * Does not understand most of ld's options. * Can be partially replaced by llvm-link | opt | {llc | as, llc -filetype=obj} | ld, or fully replaced by Clang. I know of no production use of llvm-ld, and hacking use should be replaced by Clang's driver. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@155147 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-ld/CMakeLists.txt')
-rw-r--r--tools/llvm-ld/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/tools/llvm-ld/CMakeLists.txt b/tools/llvm-ld/CMakeLists.txt
deleted file mode 100644
index d328a04b0e..0000000000
--- a/tools/llvm-ld/CMakeLists.txt
+++ /dev/null
@@ -1,8 +0,0 @@
-set(LLVM_LINK_COMPONENTS ipo scalaropts linker archive bitwriter vectorize)
-
-add_llvm_tool(llvm-ld
- Optimize.cpp
- llvm-ld.cpp
- )
-
-add_dependencies(llvm-ld llvm-stub)