summaryrefslogtreecommitdiff
path: root/tools/llvm-ld/CMakeLists.txt
diff options
context:
space:
mode:
authorHal Finkel <hfinkel@anl.gov>2012-02-01 03:51:43 +0000
committerHal Finkel <hfinkel@anl.gov>2012-02-01 03:51:43 +0000
commitde5e5ec3045a73a06b1054417f9ac6c02929e9ce (patch)
tree02f43070729c0328db2d86e33acd94df3ab52d53 /tools/llvm-ld/CMakeLists.txt
parentd0e277d272d517ca1cda368267d199f0da7cad95 (diff)
downloadllvm-de5e5ec3045a73a06b1054417f9ac6c02929e9ce.tar.gz
llvm-de5e5ec3045a73a06b1054417f9ac6c02929e9ce.tar.bz2
llvm-de5e5ec3045a73a06b1054417f9ac6c02929e9ce.tar.xz
Add a basic-block autovectorization pass.
This is the initial checkin of the basic-block autovectorization pass along with some supporting vectorization infrastructure. Special thanks to everyone who helped review this code over the last several months (especially Tobias Grosser). git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@149468 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-ld/CMakeLists.txt')
-rw-r--r--tools/llvm-ld/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/llvm-ld/CMakeLists.txt b/tools/llvm-ld/CMakeLists.txt
index 370bcb4abf..d328a04b0e 100644
--- a/tools/llvm-ld/CMakeLists.txt
+++ b/tools/llvm-ld/CMakeLists.txt
@@ -1,4 +1,4 @@
-set(LLVM_LINK_COMPONENTS ipo scalaropts linker archive bitwriter)
+set(LLVM_LINK_COMPONENTS ipo scalaropts linker archive bitwriter vectorize)
add_llvm_tool(llvm-ld
Optimize.cpp