summaryrefslogtreecommitdiff
path: root/tools/opt/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Gottesman <mgottesman@apple.com>2013-01-28 01:35:51 +0000
committerMichael Gottesman <mgottesman@apple.com>2013-01-28 01:35:51 +0000
commit24c4898973a074713201fb9351d302b9f7733e92 (patch)
treef43dcb2d89136a2f7e532fd5b76b471f20e9021a /tools/opt/CMakeLists.txt
parenta9b9f0ad802ef6973534a9a247716e4a8e079635 (diff)
downloadllvm-24c4898973a074713201fb9351d302b9f7733e92.tar.gz
llvm-24c4898973a074713201fb9351d302b9f7733e92.tar.bz2
llvm-24c4898973a074713201fb9351d302b9f7733e92.tar.xz
Extracted ObjCARC.cpp into its own library libLLVMObjCARCOpts in preparation for refactoring the ARC Optimizer.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@173647 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/opt/CMakeLists.txt')
-rw-r--r--tools/opt/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/opt/CMakeLists.txt b/tools/opt/CMakeLists.txt
index 32de6d4060..cf5e5a83cf 100644
--- a/tools/opt/CMakeLists.txt
+++ b/tools/opt/CMakeLists.txt
@@ -1,4 +1,4 @@
-set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} bitreader asmparser bitwriter instrumentation scalaropts ipo vectorize)
+set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} bitreader asmparser bitwriter instrumentation scalaropts objcarcopts ipo vectorize)
add_llvm_tool(opt
AnalysisWrappers.cpp