summaryrefslogtreecommitdiff
path: root/tools/opt/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-09-22 01:08:49 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-09-22 01:08:49 +0000
commit3d01fc7de86c75926e4e5ac7cc49f0116018893d (patch)
tree2ea49e2f904dd479a4b941454b776dee762921dd /tools/opt/CMakeLists.txt
parentcd4c73aa708d9ecf5d7e0a711dbf359d22b6dd3a (diff)
downloadllvm-3d01fc7de86c75926e4e5ac7cc49f0116018893d.tar.gz
llvm-3d01fc7de86c75926e4e5ac7cc49f0116018893d.tar.bz2
llvm-3d01fc7de86c75926e4e5ac7cc49f0116018893d.tar.xz
Initial support for the CMake build system.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@56419 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/opt/CMakeLists.txt')
-rw-r--r--tools/opt/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/tools/opt/CMakeLists.txt b/tools/opt/CMakeLists.txt
new file mode 100644
index 0000000000..efcca80ddf
--- /dev/null
+++ b/tools/opt/CMakeLists.txt
@@ -0,0 +1,9 @@
+set(LLVM_REQUIRES_EH 1)
+set(LLVM_LINK_COMPONENTS bitreader bitwriter instrumentation scalaropts ipo)
+
+add_llvm_tool(opt
+ AnalysisWrappers.cpp
+ GraphPrinters.cpp
+ PrintSCC.cpp
+ opt.cpp
+ )