summaryrefslogtreecommitdiff
path: root/tools/opt/CMakeLists.txt
diff options
context:
space:
mode:
authorEli Bendersky <eliben@google.com>2014-02-10 23:34:23 +0000
committerEli Bendersky <eliben@google.com>2014-02-10 23:34:23 +0000
commit8ed971b988512f059ac2cdf11f469b04d54f4f11 (patch)
tree4029227454fed88421e3cd92879408c606cd888f /tools/opt/CMakeLists.txt
parent1a66b635780c22de07bc2ce12e2ff832d6698668 (diff)
downloadllvm-8ed971b988512f059ac2cdf11f469b04d54f4f11.tar.gz
llvm-8ed971b988512f059ac2cdf11f469b04d54f4f11.tar.bz2
llvm-8ed971b988512f059ac2cdf11f469b04d54f4f11.tar.xz
Move the *PassPrinter into their own module.
These are self-contained in functionality so it makes sense to separate them, as opt.cpp has grown quite big already. Following Eric's suggestions, if this code is ever deemed useful outside of tools/opt, it will make sense to move it to one of the LLVM libraries like IR. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@201116 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/opt/CMakeLists.txt')
-rw-r--r--tools/opt/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/opt/CMakeLists.txt b/tools/opt/CMakeLists.txt
index c007e0fa2e..6e7bea78f1 100644
--- a/tools/opt/CMakeLists.txt
+++ b/tools/opt/CMakeLists.txt
@@ -25,6 +25,7 @@ add_llvm_tool(opt
GraphPrinters.cpp
NewPMDriver.cpp
Passes.cpp
+ PassPrinters.cpp
PrintSCC.cpp
opt.cpp
)