summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-09-24 09:01:13 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-09-24 09:01:13 +0000
commitee6944f4ab4258e6b7b9c91c0c18444193d6f55a (patch)
treef2ae8d853d901e248eeee9abc7dcf66b7bd5c02b /unittests/CMakeLists.txt
parentc8417d7165e156739cd768713db0113383ede07e (diff)
downloadllvm-ee6944f4ab4258e6b7b9c91c0c18444193d6f55a.tar.gz
llvm-ee6944f4ab4258e6b7b9c91c0c18444193d6f55a.tar.bz2
llvm-ee6944f4ab4258e6b7b9c91c0c18444193d6f55a.tar.xz
CMake: Build unittests.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@114725 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt95
1 files changed, 95 insertions, 0 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
new file mode 100644
index 0000000000..595ec21454
--- /dev/null
+++ b/unittests/CMakeLists.txt
@@ -0,0 +1,95 @@
+function(add_llvm_unittest test_name)
+ if (CMAKE_BUILD_TYPE)
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY
+ ${LLVM_BINARY_DIR}/unittests/${test_name}/${CMAKE_BUILD_TYPE})
+ else()
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY
+ ${LLVM_BINARY_DIR}/unittests/${test_name})
+ endif()
+ if( NOT LLVM_BUILD_TESTS )
+ set(EXCLUDE_FROM_ALL ON)
+ endif()
+ add_llvm_executable(${test_name}Tests ${ARGN})
+endfunction()
+
+include_directories(${LLVM_MAIN_SRC_DIR}/utils/unittest/googletest/include)
+
+set(LLVM_LINK_COMPONENTS
+ jit
+ interpreter
+ nativecodegen
+ BitWriter
+ BitReader
+ AsmParser
+ Core
+ System
+ Support
+ )
+
+set(LLVM_USED_LIBS
+ gtest
+ gtest_main
+ )
+
+add_llvm_unittest(ADT
+ ADT/APFloatTest.cpp
+ ADT/APIntTest.cpp
+ ADT/BitVectorTest.cpp
+ ADT/DAGDeltaAlgorithmTest.cpp
+ ADT/DeltaAlgorithmTest.cpp
+ ADT/DenseMapTest.cpp
+ ADT/DenseSetTest.cpp
+ ADT/ilistTest.cpp
+ ADT/ImmutableSetTest.cpp
+ ADT/SmallBitVectorTest.cpp
+ ADT/SmallStringTest.cpp
+ ADT/SmallVectorTest.cpp
+ ADT/SparseBitVectorTest.cpp
+ ADT/StringMapTest.cpp
+ ADT/StringRefTest.cpp
+ ADT/TripleTest.cpp
+ ADT/TwineTest.cpp
+ ADT/ValueMapTest.cpp
+ )
+
+add_llvm_unittest(Analysis
+ Analysis/ScalarEvolutionTest.cpp
+ )
+
+add_llvm_unittest(ExecutionEngine
+ ExecutionEngine/ExecutionEngineTest.cpp
+ )
+
+add_llvm_unittest(JIT
+ ExecutionEngine/JIT/JITEventListenerTest.cpp
+ ExecutionEngine/JIT/JITMemoryManagerTest.cpp
+ ExecutionEngine/JIT/JITTest.cpp
+ ExecutionEngine/JIT/MultiJITTest.cpp
+ )
+
+add_llvm_unittest(Support
+ Support/AllocatorTest.cpp
+ Support/Casting.cpp
+ Support/CommandLineTest.cpp
+ Support/ConstantRangeTest.cpp
+ Support/LeakDetectorTest.cpp
+ Support/MathExtrasTest.cpp
+ Support/raw_ostream_test.cpp
+ Support/RegexTest.cpp
+ Support/System.cpp
+ Support/TypeBuilderTest.cpp
+ Support/ValueHandleTest.cpp
+ )
+
+add_llvm_unittest(Transforms
+ Transforms/Utils/Cloning.cpp
+ )
+
+add_llvm_unittest(VMCore
+ VMCore/ConstantsTest.cpp
+ VMCore/DerivedTypesTest.cpp
+ VMCore/InstructionsTest.cpp
+ VMCore/MetadataTest.cpp
+ VMCore/PassManagerTest.cpp
+ VMCore/VerifierTest.cpp
+ )