summaryrefslogtreecommitdiff
path: root/unittests/DebugInfo/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-04-17 08:29:02 +0000
committerAlexey Samsonov <samsonov@google.com>2013-04-17 08:29:02 +0000
commitcd61455798777446f35723fdb77f54a17e602009 (patch)
tree2444497f48eec7342a67e3899a1d4148b2bda2ad /unittests/DebugInfo/CMakeLists.txt
parentce47d5ba8cf7e30cbf0d6b80d3f7d10916c7fe31 (diff)
downloadllvm-cd61455798777446f35723fdb77f54a17e602009.tar.gz
llvm-cd61455798777446f35723fdb77f54a17e602009.tar.bz2
llvm-cd61455798777446f35723fdb77f54a17e602009.tar.xz
Create a stub for DWARF parser unittests
Moves one DWARF-specific header to include/llvm/DebugInfo from lib/. Add a short unittest for r179095. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@179678 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/DebugInfo/CMakeLists.txt')
-rw-r--r--unittests/DebugInfo/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/unittests/DebugInfo/CMakeLists.txt b/unittests/DebugInfo/CMakeLists.txt
new file mode 100644
index 0000000000..ec580b7f69
--- /dev/null
+++ b/unittests/DebugInfo/CMakeLists.txt
@@ -0,0 +1,13 @@
+set(LLVM_LINK_COMPONENTS
+ debuginfo
+ object
+ support
+ )
+
+set(DebugInfoSources
+ DWARFFormValueTest.cpp
+ )
+
+add_llvm_unittest(DebugInfoTests
+ ${DebugInfoSources}
+ )