summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Kledzik <kledzik@apple.com>2012-12-12 20:46:15 +0000
committerNick Kledzik <kledzik@apple.com>2012-12-12 20:46:15 +0000
commit8ceb8b764f266ff00a590c88a7ecc654b13a8f0b (patch)
tree4e268396d14509d5b6b7dc3cc6828c71b5f09c6c /unittests/Support/CMakeLists.txt
parenta16e49d56f6349c12da2b561da00c22e13eda09b (diff)
downloadllvm-8ceb8b764f266ff00a590c88a7ecc654b13a8f0b.tar.gz
llvm-8ceb8b764f266ff00a590c88a7ecc654b13a8f0b.tar.bz2
llvm-8ceb8b764f266ff00a590c88a7ecc654b13a8f0b.tar.xz
Initial implementation of a utility for converting native data
structures to and from YAML using traits. The first client will be the test suite of lld. The documentation will show up at: http://llvm.org/docs/YamlIO.html git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@170019 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index 09a0ea50d7..f6a5949cdb 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -24,6 +24,7 @@ add_llvm_unittest(SupportTests
SwapByteOrderTest.cpp
TimeValue.cpp
ValueHandleTest.cpp
+ YAMLIOTest.cpp
YAMLParserTest.cpp
formatted_raw_ostream_test.cpp
raw_ostream_test.cpp