summaryrefslogtreecommitdiff
path: root/utils/KillTheDoctor/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-11-16 18:31:52 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-11-16 18:31:52 +0000
commitfae76d0734562b6422c51fe3207cca8a51666323 (patch)
treec6d48807beab1e46d8ac6c036ed955266686fdfa /utils/KillTheDoctor/CMakeLists.txt
parentf93cbbd72ed15a6f0c2e03bfe7729e4b847566be (diff)
downloadllvm-fae76d0734562b6422c51fe3207cca8a51666323.tar.gz
llvm-fae76d0734562b6422c51fe3207cca8a51666323.tar.bz2
llvm-fae76d0734562b6422c51fe3207cca8a51666323.tar.xz
This is the first step in adding sane error handling support to LLVMSystem.
The system API's will be shifted over to returning an error_code, and returning other return values as out parameters to the function. Code that needs to check error conditions will use the errc enum values which are the same as the posix_errno defines (EBADF, E2BIG, etc...), and are compatable with the error codes in WinError.h due to some magic in system_error. An example would be: if (error_code ec = KillEvil("Java")) { // error_code can be converted to bool. handle_error(ec); } git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@119360 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'utils/KillTheDoctor/CMakeLists.txt')
-rw-r--r--utils/KillTheDoctor/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/utils/KillTheDoctor/CMakeLists.txt b/utils/KillTheDoctor/CMakeLists.txt
index 32e481cbea..fc6fa9b508 100644
--- a/utils/KillTheDoctor/CMakeLists.txt
+++ b/utils/KillTheDoctor/CMakeLists.txt
@@ -1,6 +1,5 @@
add_executable(KillTheDoctor
KillTheDoctor.cpp
- system_error.cpp
)
target_link_libraries(KillTheDoctor LLVMSupport LLVMSystem)