summaryrefslogtreecommitdiff
path: root/utils/unittest/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-09-24 09:01:13 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-09-24 09:01:13 +0000
commitee6944f4ab4258e6b7b9c91c0c18444193d6f55a (patch)
treef2ae8d853d901e248eeee9abc7dcf66b7bd5c02b /utils/unittest/CMakeLists.txt
parentc8417d7165e156739cd768713db0113383ede07e (diff)
downloadllvm-ee6944f4ab4258e6b7b9c91c0c18444193d6f55a.tar.gz
llvm-ee6944f4ab4258e6b7b9c91c0c18444193d6f55a.tar.bz2
llvm-ee6944f4ab4258e6b7b9c91c0c18444193d6f55a.tar.xz
CMake: Build unittests.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@114725 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'utils/unittest/CMakeLists.txt')
-rw-r--r--utils/unittest/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/utils/unittest/CMakeLists.txt b/utils/unittest/CMakeLists.txt
new file mode 100644
index 0000000000..7068546301
--- /dev/null
+++ b/utils/unittest/CMakeLists.txt
@@ -0,0 +1,34 @@
+########################################################################
+# Experimental CMake build script for Google Test.
+#
+# Consider this a prototype. It will change drastically. For now,
+# this is only for people on the cutting edge.
+#
+# To run the tests for Google Test itself on Linux, use 'make test' or
+# ctest. You can select which tests to run using 'ctest -R regex'.
+# For more options, run 'ctest --help'.
+########################################################################
+#
+# Project-wide settings
+
+# Where gtest's .h files can be found.
+include_directories(
+ googletest/include
+ )
+
+if(WIN32)
+ add_definitions(-DGTEST_OS_WINDOWS=1)
+endif()
+
+add_llvm_library(gtest
+ googletest/gtest.cc
+ googletest/gtest-death-test.cc
+ googletest/gtest-filepath.cc
+ googletest/gtest-port.cc
+ googletest/gtest-test-part.cc
+ googletest/gtest-typed-test.cc
+ )
+
+add_llvm_library(gtest_main
+ UnitTestMain/TestMain.cpp
+ )