summaryrefslogtreecommitdiff
path: root/utils/unittest/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2013-11-15 10:20:45 +0000
committerChandler Carruth <chandlerc@gmail.com>2013-11-15 10:20:45 +0000
commitefbdf7f2320649512569143611f53177c27ba9f6 (patch)
tree86dee0c1deeeb151c86a8e02cb10a6ab695903f4 /utils/unittest/CMakeLists.txt
parent8f15c6822251bbe7eb21732c46aa6d9f30ba8836 (diff)
downloadllvm-efbdf7f2320649512569143611f53177c27ba9f6.tar.gz
llvm-efbdf7f2320649512569143611f53177c27ba9f6.tar.bz2
llvm-efbdf7f2320649512569143611f53177c27ba9f6.tar.xz
Move all of the GoogleTest files back to the same locations they occupy
externally to simplify our integration of GoogleTest into LLVM. Also, build the single source file gtest-all.cc instead of the individual source files as we don't expect these to change and thus gain nothing from increased incrementality in compiles. This makes our standard build of googletest exactly like upstream's recommended build and the sanitizer's build. It also simplifies the steps of importing a new version should we ever want one. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@194801 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'utils/unittest/CMakeLists.txt')
-rw-r--r--utils/unittest/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/utils/unittest/CMakeLists.txt b/utils/unittest/CMakeLists.txt
index 8bdfee15c1..fd1a048d83 100644
--- a/utils/unittest/CMakeLists.txt
+++ b/utils/unittest/CMakeLists.txt
@@ -14,6 +14,7 @@
# Where gtest's .h files can be found.
include_directories(
googletest/include
+ googletest
)
if(WIN32)
@@ -38,13 +39,7 @@ if(MSVC AND MSVC_VERSION EQUAL 1700)
endif ()
add_llvm_library(gtest
- googletest/gtest.cc
- googletest/gtest-death-test.cc
- googletest/gtest-filepath.cc
- googletest/gtest-port.cc
- googletest/gtest-printers.cc
- googletest/gtest-test-part.cc
- googletest/gtest-typed-test.cc
+ googletest/src/gtest-all.cc
)
add_llvm_library(gtest_main