summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 709fbb5ba3..58c54d3720 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -422,6 +422,17 @@ if test "$with_default_cpu" != "Unknown" ; then
[Default cpu (-mcpu=cpu) to use to all compiler invocations.])
fi
+dnl Default cpu (-mabi=abi) to use to all compiler invocations
+AC_ARG_WITH(default-abi,
+ AS_HELP_STRING([--with-default-abi],
+ [Add by default -mabi=abi to all compiler invocations.]),,
+ with_default_abi="Unknown")
+
+if test "$with_default_abi" != "Unknown" ; then
+ AC_DEFINE_UNQUOTED(DEFAULT_TARGET_ABI,"$with_default_abi",
+ [Default abi (-mabi=abi) to use to all compiler invocations.])
+fi
+
dnl Default float abi to use to all compiler invocations
AC_ARG_WITH(default-float,
AS_HELP_STRING([--with-default-float],