summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 7babb90767..3756c4f9ce 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -422,6 +422,17 @@ if test "$withval" != "Unknown" ; then
[Default cpu (-mcpu=cpu) to use to all compiler invocations.])
fi
+dnl Default float abi to use to all compiler invocations
+AC_ARG_WITH(default-float,
+ AS_HELP_STRING([--with-default-float],
+ [Default float abi to use to all compiler invocations.]),,
+ withval="Unknown")
+
+if test "$withval" != "Unknown" ; then
+ AC_DEFINE_UNQUOTED(DEFAULT_TARGET_FLOAT,"$withval",
+ [Default float abi to use to all compiler invocations.])
+fi
+
dnl Check for the endianness of the target
AC_C_BIGENDIAN(AC_SUBST([ENDIAN],[big]),AC_SUBST([ENDIAN],[little]))