summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 0a2c8b69dd..a3961efe1b 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -838,6 +838,13 @@ AC_ARG_WITH(gcc-toolchain,
AC_DEFINE_UNQUOTED(GCC_INSTALL_PREFIX,"$withval",
[Directory where gcc is installed.])
+AC_ARG_WITH(sysroot,
+ AS_HELP_STRING([--with-default-sysroot],
+ [Add --sysroot=<path> to all compiler invocations.]),,
+ withval="")
+AC_DEFINE_UNQUOTED(DEFAULT_SYSROOT,"$withval",
+ [Default <path> to all compiler invocations for --sysroot=<path>.])
+
dnl Allow linking of LLVM with GPLv3 binutils code.
AC_ARG_WITH(binutils-include,
AS_HELP_STRING([--with-binutils-include],