summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 3756c4f9ce..3fe6d42009 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -433,6 +433,17 @@ if test "$withval" != "Unknown" ; then
[Default float abi to use to all compiler invocations.])
fi
+dnl Default FPU to use to all compiler invocations, in case of hard float
+AC_ARG_WITH(default-float,
+ AS_HELP_STRING([--with-default-fpu],
+ [Default FPU to use to all compiler invocations, in case of hard float.]),,
+ withval="Unknown")
+
+if test "$withval" != "Unknown" ; then
+ AC_DEFINE_UNQUOTED(DEFAULT_TARGET_FPU,"$withval",
+ [Default FPU to use to all compiler invocations, in case of hard float.])
+fi
+
dnl Check for the endianness of the target
AC_C_BIGENDIAN(AC_SUBST([ENDIAN],[big]),AC_SUBST([ENDIAN],[little]))