summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac47
1 files changed, 47 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index a5caac971b..ffd155d2e2 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -446,6 +446,53 @@ fi
AC_SUBST(HOST_ARCH,$host_arch)
+dnl Default cpu (-mcpu=cpu) to use to all compiler invocations
+AC_ARG_WITH(default-cpu,
+ AS_HELP_STRING([--with-default-cpu],
+ [Add by default -mcpu=cpu to all compiler invocations.]),,
+ with_default_cpu="")
+AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_MCPU],"$with_default_cpu",
+ [Default cpu (-mcpu=cpu) to use to all compiler invocations.])
+
+dnl Default float abi to use to all compiler invocations
+AC_ARG_WITH(default-float,
+ AS_HELP_STRING([--with-default-float],
+ [Default float abi to use to all compiler invocations.]),,
+ with_default_float="")
+AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_FLOAT],"$with_default_float",
+ [Default float abi to use to all compiler invocations.])
+
+dnl Default FPU to use to all compiler invocations, in case of hard float
+AC_ARG_WITH(default-float,
+ AS_HELP_STRING([--with-default-fpu],
+ [Default FPU to use to all compiler invocations, in case of hard float.]),,
+ with_default_fpu="")
+AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_FPU],"$with_default_fpu",
+ [Default FPU to use to all compiler invocations, in case of hard float.])
+
+dnl Default hash-style to use to all linker invocations.
+AC_ARG_WITH(default-hash-style,
+ AC_ARG_WITH(default-hash-style,
+ [Default hash-style to use to all linker invocations: gnu, sysv or both.]),,
+ with_default_hash_style="")
+if test "x$with_default_hash_style" != "x" ; then
+ case "$with_default_hash_style" in
+ gnu|sysv|both);;
+ *)
+ AC_MSG_ERROR([Invalid --with-default-hash-style. Use "sysv", "gnu" or "both"]);;
+ esac
+fi
+AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_HASHSTYLE],"$with_default_hash_style",
+ [Default hash-style to use to all linker invocations.])
+
+dnl Default cpu (-mabi=abi) to use to all compiler invocations
+AC_ARG_WITH(default-abi,
+ AS_HELP_STRING([--with-default-abi],
+ [Add by default -mabi=abi (if --with-default-abi=abi) to all compiler invocations.]),,
+ with_default_abi="")
+AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_ABI],"$with_default_abi",
+ [Add by default -mabi=abi to all compiler invocations.])
+
dnl Check for the endianness of the target
AC_C_BIGENDIAN(AC_SUBST([ENDIAN],[big]),AC_SUBST([ENDIAN],[little]))