summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 2fc17f86af..7f62a66ff2 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -488,6 +488,21 @@ AC_ARG_WITH(default-float,
AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_FPU],"$with_default_fpu",
[Default FPU to use to all compiler invocations, in case of hard float.])
+dnl Default hash-style to use to all linker invocations.
+AC_ARG_WITH(default-hash-style,
+ AC_ARG_WITH(default-hash-style,
+ [Default hash-style to use to all linker invocations: gnu, sysv or both.]),,
+ with_default_hash_style="")
+if test "x$with_default_hash_style" != "x" ; then
+ case "$with_default_hash_style" in
+ gnu|sysv|both);;
+ *)
+ AC_MSG_ERROR([Invalid --with-default-hash-style. Use "sysv", "gnu" or "both"]);;
+ esac
+fi
+AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_HASHSTYLE],"$with_default_hash_style",
+ [Default hash-style to use to all linker invocations.])
+
dnl Check for the endianness of the target
AC_C_BIGENDIAN(AC_SUBST([ENDIAN],[big]),AC_SUBST([ENDIAN],[little]))