summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 2da5a19aeb..2fc17f86af 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -480,6 +480,14 @@ AC_ARG_WITH(default-float,
AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_FLOAT],"$with_default_float",
[Default float abi to use to all compiler invocations.])
+dnl Default FPU to use to all compiler invocations, in case of hard float
+AC_ARG_WITH(default-float,
+ AS_HELP_STRING([--with-default-fpu],
+ [Default FPU to use to all compiler invocations, in case of hard float.]),,
+ with_default_fpu="")
+AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_FPU],"$with_default_fpu",
+ [Default FPU to use to all compiler invocations, in case of hard float.])
+
dnl Check for the endianness of the target
AC_C_BIGENDIAN(AC_SUBST([ENDIAN],[big]),AC_SUBST([ENDIAN],[little]))