summaryrefslogtreecommitdiff
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index a44b228334..2da5a19aeb 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -472,6 +472,14 @@ AC_ARG_WITH(default-cpu,
AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_MCPU],"$with_default_cpu",
[Default cpu (-mcpu=cpu) to use to all compiler invocations.])
+dnl Default float abi to use to all compiler invocations
+AC_ARG_WITH(default-float,
+ AS_HELP_STRING([--with-default-float],
+ [Default float abi to use to all compiler invocations.]),,
+ with_default_float="")
+AC_DEFINE_UNQUOTED([LLVM_DEFAULT_TARGET_FLOAT],"$with_default_float",
+ [Default float abi to use to all compiler invocations.])
+
dnl Check for the endianness of the target
AC_C_BIGENDIAN(AC_SUBST([ENDIAN],[big]),AC_SUBST([ENDIAN],[little]))