summaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/Chapter6/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/Chapter6/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/Chapter6/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/examples/Kaleidoscope/Chapter6/CMakeLists.txt b/examples/Kaleidoscope/Chapter6/CMakeLists.txt
index 2e15a5f7df..669c7eb171 100644
--- a/examples/Kaleidoscope/Chapter6/CMakeLists.txt
+++ b/examples/Kaleidoscope/Chapter6/CMakeLists.txt
@@ -1,4 +1,13 @@
-set(LLVM_LINK_COMPONENTS core jit interpreter native)
+set(LLVM_LINK_COMPONENTS
+ Analysis
+ Core
+ ExecutionEngine
+ InstCombine
+ JIT
+ ScalarOpts
+ Support
+ nativecodegen
+ )
add_llvm_example(Kaleidoscope-Ch6
toy.cpp