summaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/Chapter7/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/Chapter7/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/Chapter7/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/examples/Kaleidoscope/Chapter7/CMakeLists.txt b/examples/Kaleidoscope/Chapter7/CMakeLists.txt
index da3839843b..0a0c8e7cab 100644
--- a/examples/Kaleidoscope/Chapter7/CMakeLists.txt
+++ b/examples/Kaleidoscope/Chapter7/CMakeLists.txt
@@ -1,4 +1,15 @@
-set(LLVM_LINK_COMPONENTS core jit interpreter native)
+set(LLVM_LINK_COMPONENTS
+ Analysis
+ Core
+ ExecutionEngine
+ InstCombine
+ JIT
+ ScalarOpts
+ Support
+ TransformUtils
+ nativecodegen
+ )
+
set(LLVM_REQUIRES_RTTI 1)
add_llvm_example(Kaleidoscope-Ch7