summaryrefslogtreecommitdiff
path: root/lib/CodeGen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CodeGen/CMakeLists.txt')
-rw-r--r--lib/CodeGen/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/lib/CodeGen/CMakeLists.txt b/lib/CodeGen/CMakeLists.txt
new file mode 100644
index 0000000000..5d15746c0f
--- /dev/null
+++ b/lib/CodeGen/CMakeLists.txt
@@ -0,0 +1,48 @@
+add_llvm_library(LLVMCodeGen
+ BranchFolding.cpp
+ DeadMachineInstructionElim.cpp
+ ELFWriter.cpp
+ GCMetadata.cpp
+ GCMetadataPrinter.cpp
+ GCStrategy.cpp
+ IfConversion.cpp
+ IntrinsicLowering.cpp
+ LLVMTargetMachine.cpp
+ LiveInterval.cpp
+ LiveIntervalAnalysis.cpp
+ LiveStackAnalysis.cpp
+ LiveVariables.cpp
+ LoopAligner.cpp
+ LowerSubregs.cpp
+ MachOWriter.cpp
+ MachineBasicBlock.cpp
+ MachineDominators.cpp
+ MachineFunction.cpp
+ MachineInstr.cpp
+ MachineLICM.cpp
+ MachineLoopInfo.cpp
+ MachineModuleInfo.cpp
+ MachinePassRegistry.cpp
+ MachineRegisterInfo.cpp
+ MachineSink.cpp
+ OcamlGC.cpp
+ PHIElimination.cpp
+ Passes.cpp
+ PostRASchedulerList.cpp
+ PrologEpilogInserter.cpp
+ PseudoSourceValue.cpp
+ RegAllocBigBlock.cpp
+ RegAllocLinearScan.cpp
+ RegAllocLocal.cpp
+ RegAllocSimple.cpp
+ RegisterCoalescer.cpp
+ RegisterScavenging.cpp
+ ShadowStackGC.cpp
+ SimpleRegisterCoalescing.cpp
+ StackSlotColoring.cpp
+ StrongPHIElimination.cpp
+ TargetInstrInfoImpl.cpp
+ TwoAddressInstructionPass.cpp
+ UnreachableBlockElim.cpp
+ VirtRegMap.cpp
+ )