summaryrefslogtreecommitdiff
path: root/lib/Target/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Target/CMakeLists.txt')
-rw-r--r--lib/Target/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/Target/CMakeLists.txt b/lib/Target/CMakeLists.txt
new file mode 100644
index 0000000000..1cf0a91078
--- /dev/null
+++ b/lib/Target/CMakeLists.txt
@@ -0,0 +1,17 @@
+add_llvm_library(LLVMTarget
+ DarwinTargetAsmInfo.cpp
+ ELFTargetAsmInfo.cpp
+ SubtargetFeature.cpp
+ Target.cpp
+ TargetAsmInfo.cpp
+ TargetData.cpp
+ TargetFrameInfo.cpp
+ TargetInstrInfo.cpp
+ TargetMachOWriterInfo.cpp
+ TargetMachine.cpp
+ TargetMachineRegistry.cpp
+ TargetRegisterInfo.cpp
+ TargetSubtarget.cpp
+ )
+
+# TODO: Support other targets besides X86. See Makefile. \ No newline at end of file