summaryrefslogtreecommitdiff
path: root/lib/Transforms/Scalar/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Transforms/Scalar/CMakeLists.txt')
-rw-r--r--lib/Transforms/Scalar/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Transforms/Scalar/CMakeLists.txt b/lib/Transforms/Scalar/CMakeLists.txt
index 69b4c341c5..b7598eace5 100644
--- a/lib/Transforms/Scalar/CMakeLists.txt
+++ b/lib/Transforms/Scalar/CMakeLists.txt
@@ -3,6 +3,7 @@ add_llvm_library(LLVMScalarOpts
BasicBlockPlacement.cpp
CodeGenPrepare.cpp
ConstantProp.cpp
+ CorrelatedValuePropagation.cpp
DCE.cpp
DeadStoreElimination.cpp
GEPSplitter.cpp
@@ -29,7 +30,6 @@ add_llvm_library(LLVMScalarOpts
Sink.cpp
TailDuplication.cpp
TailRecursionElimination.cpp
- ValuePropagation.cpp
)
target_link_libraries (LLVMScalarOpts LLVMTransformUtils)