summaryrefslogtreecommitdiff
path: root/lib/Transforms/Utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Transforms/Utils/CMakeLists.txt')
-rw-r--r--lib/Transforms/Utils/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/Transforms/Utils/CMakeLists.txt b/lib/Transforms/Utils/CMakeLists.txt
new file mode 100644
index 0000000000..b678b2e377
--- /dev/null
+++ b/lib/Transforms/Utils/CMakeLists.txt
@@ -0,0 +1,26 @@
+add_llvm_library(LLVMTransformUtils
+ BasicBlockUtils.cpp
+ BasicInliner.cpp
+ BreakCriticalEdges.cpp
+ CloneFunction.cpp
+ CloneLoop.cpp
+ CloneModule.cpp
+ CloneTrace.cpp
+ CodeExtractor.cpp
+ DemoteRegToStack.cpp
+ InlineCost.cpp
+ InlineFunction.cpp
+ LCSSA.cpp
+ Local.cpp
+ LoopSimplify.cpp
+ LowerAllocations.cpp
+ LowerInvoke.cpp
+ LowerSwitch.cpp
+ Mem2Reg.cpp
+ PromoteMemoryToRegister.cpp
+ SimplifyCFG.cpp
+ UnifyFunctionExitNodes.cpp
+ UnrollLoop.cpp
+ ValueMapper.cpp
+ InstructionNamer.cpp
+ )