summaryrefslogtreecommitdiff
path: root/lib/VMCore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/VMCore/CMakeLists.txt')
-rw-r--r--lib/VMCore/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/lib/VMCore/CMakeLists.txt b/lib/VMCore/CMakeLists.txt
new file mode 100644
index 0000000000..a7243c3284
--- /dev/null
+++ b/lib/VMCore/CMakeLists.txt
@@ -0,0 +1,32 @@
+add_llvm_library(LLVMVMCore
+ AsmWriter.cpp
+ AutoUpgrade.cpp
+ BasicBlock.cpp
+ ConstantFold.cpp
+ Constants.cpp
+ Core.cpp
+ DebugInfoBuilder.cpp
+ Dominators.cpp
+ Function.cpp
+ Globals.cpp
+ InlineAsm.cpp
+ Instruction.cpp
+ Instructions.cpp
+ IntrinsicInst.cpp
+ LeakDetector.cpp
+ Mangler.cpp
+ Module.cpp
+ ModuleProvider.cpp
+ ParameterAttributes.cpp
+ Pass.cpp
+ PassManager.cpp
+ Type.cpp
+ TypeSymbolTable.cpp
+ Use.cpp
+ Value.cpp
+ ValueSymbolTable.cpp
+ ValueTypes.cpp
+ Verifier.cpp
+ )
+
+add_dependencies( LLVMVMCore ${llvm_builded_incs_dir}/Intrinsics.gen ) \ No newline at end of file