summaryrefslogtreecommitdiff
path: root/projects/sample/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'projects/sample/autoconf/configure.ac')
-rw-r--r--projects/sample/autoconf/configure.ac34
1 files changed, 8 insertions, 26 deletions
diff --git a/projects/sample/autoconf/configure.ac b/projects/sample/autoconf/configure.ac
index a19e87ddf9..1caff51112 100644
--- a/projects/sample/autoconf/configure.ac
+++ b/projects/sample/autoconf/configure.ac
@@ -745,33 +745,15 @@ AC_ARG_WITH(c-include-dirs,
AC_DEFINE_UNQUOTED(C_INCLUDE_DIRS,"$withval",
[Directories clang will search for headers])
-AC_ARG_WITH(cxx-include-root,
- AS_HELP_STRING([--with-cxx-include-root],
- [Directory with the libstdc++ headers.]),,
+# Clang normally uses the system c++ headers and libraries. With this option,
+# clang will use the ones provided by a gcc installation instead. This option should
+# be passed the same value that was used with --prefix when configuring gcc.
+AC_ARG_WITH(gcc-toolchain,
+ AS_HELP_STRING([--with-gcc-toolchain],
+ [Directory where gcc is installed.]),,
withval="")
-AC_DEFINE_UNQUOTED(CXX_INCLUDE_ROOT,"$withval",
- [Directory with the libstdc++ headers.])
-
-AC_ARG_WITH(cxx-include-arch,
- AS_HELP_STRING([--with-cxx-include-arch],
- [Architecture of the libstdc++ headers.]),,
- withval="")
-AC_DEFINE_UNQUOTED(CXX_INCLUDE_ARCH,"$withval",
- [Arch the libstdc++ headers.])
-
-AC_ARG_WITH(cxx-include-32bit-dir,
- AS_HELP_STRING([--with-cxx-include-32bit-dir],
- [32 bit multilib dir.]),,
- withval="")
-AC_DEFINE_UNQUOTED(CXX_INCLUDE_32BIT_DIR,"$withval",
- [32 bit multilib directory.])
-
-AC_ARG_WITH(cxx-include-64bit-dir,
- AS_HELP_STRING([--with-cxx-include-64bit-dir],
- [64 bit multilib directory.]),,
- withval="")
-AC_DEFINE_UNQUOTED(CXX_INCLUDE_64BIT_DIR,"$withval",
- [64 bit multilib directory.])
+AC_DEFINE_UNQUOTED(GCC_INSTALL_PREFIX,"$withval",
+ [Directory where gcc is installed.])
dnl Allow linking of LLVM with GPLv3 binutils code.
AC_ARG_WITH(binutils-include,