summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 651d0243f1..09cb94f4bd 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -22,5 +22,6 @@ set_target_properties(check-llvm PROPERTIES FOLDER "Tests")
# Setup a legacy alias for 'check-llvm'. This will likely change to be an
# alias for 'check-all' at some point in the future.
-add_custom_target(check DEPENDS check-llvm)
+add_custom_target(check)
+add_dependencies(check check-llvm)
set_target_properties(check PROPERTIES FOLDER "Tests")