summaryrefslogtreecommitdiff
path: root/tools/lli/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/lli/CMakeLists.txt')
-rw-r--r--tools/lli/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/tools/lli/CMakeLists.txt b/tools/lli/CMakeLists.txt
index 841a0ce42f..731b61a11b 100644
--- a/tools/lli/CMakeLists.txt
+++ b/tools/lli/CMakeLists.txt
@@ -1,6 +1,18 @@
add_subdirectory(ChildTarget)
-set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser irreader selectiondag native instrumentation)
+set(LLVM_LINK_COMPONENTS
+ CodeGen
+ Core
+ ExecutionEngine
+ IRReader
+ Instrumentation
+ Interpreter
+ JIT
+ MCJIT
+ SelectionDAG
+ Support
+ native
+ )
if( LLVM_USE_OPROFILE )
set(LLVM_LINK_COMPONENTS