summaryrefslogtreecommitdiff
path: root/tools/llvm-db/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/llvm-db/CMakeLists.txt')
-rw-r--r--tools/llvm-db/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/llvm-db/CMakeLists.txt b/tools/llvm-db/CMakeLists.txt
new file mode 100644
index 0000000000..af64908171
--- /dev/null
+++ b/tools/llvm-db/CMakeLists.txt
@@ -0,0 +1,8 @@
+set(LLVM_LINK_COMPONENTS debugger)
+set(LLVM_REQUIRES_EH 1)
+
+add_llvm_tool(llvm-db
+ CLIDebugger.cpp
+ Commands.cpp
+ llvm-db.cpp
+ )