summaryrefslogtreecommitdiff
path: root/tools/llvm-ld/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/llvm-ld/CMakeLists.txt')
-rw-r--r--tools/llvm-ld/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/llvm-ld/CMakeLists.txt b/tools/llvm-ld/CMakeLists.txt
new file mode 100644
index 0000000000..51f0dc1304
--- /dev/null
+++ b/tools/llvm-ld/CMakeLists.txt
@@ -0,0 +1,7 @@
+set(LLVM_LINK_COMPONENTS ipo scalaropts linker archive bitwriter)
+set(LLVM_REQUIRES_EH 1)
+
+add_llvm_tool(llvm-ld
+ Optimize.cpp
+ llvm-ld.cpp
+ )