summaryrefslogtreecommitdiff
path: root/tools/llvm-ranlib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/llvm-ranlib/CMakeLists.txt')
-rw-r--r--tools/llvm-ranlib/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/llvm-ranlib/CMakeLists.txt b/tools/llvm-ranlib/CMakeLists.txt
new file mode 100644
index 0000000000..3116d2e4ff
--- /dev/null
+++ b/tools/llvm-ranlib/CMakeLists.txt
@@ -0,0 +1,6 @@
+set(LLVM_LINK_COMPONENTS archive)
+set(LLVM_REQUIRES_EH 1)
+
+add_llvm_tool(llvm-ranlib
+ llvm-ranlib.cpp
+ )