summaryrefslogtreecommitdiff
path: root/tools/opt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/opt/CMakeLists.txt')
-rw-r--r--tools/opt/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/tools/opt/CMakeLists.txt b/tools/opt/CMakeLists.txt
new file mode 100644
index 0000000000..efcca80ddf
--- /dev/null
+++ b/tools/opt/CMakeLists.txt
@@ -0,0 +1,9 @@
+set(LLVM_REQUIRES_EH 1)
+set(LLVM_LINK_COMPONENTS bitreader bitwriter instrumentation scalaropts ipo)
+
+add_llvm_tool(opt
+ AnalysisWrappers.cpp
+ GraphPrinters.cpp
+ PrintSCC.cpp
+ opt.cpp
+ )