summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
new file mode 100644
index 0000000000..6053994d0c
--- /dev/null
+++ b/unittests/Support/CMakeLists.txt
@@ -0,0 +1,29 @@
+set(LLVM_LINK_COMPONENTS
+ Support
+ Core
+ )
+
+add_llvm_unittest(SupportTests
+ AlignOfTest.cpp
+ AllocatorTest.cpp
+ BlockFrequencyTest.cpp
+ Casting.cpp
+ CommandLineTest.cpp
+ ConstantRangeTest.cpp
+ DataExtractorTest.cpp
+ EndianTest.cpp
+ IntegersSubsetTest.cpp
+ IRBuilderTest.cpp
+ LeakDetectorTest.cpp
+ ManagedStatic.cpp
+ MathExtrasTest.cpp
+ MDBuilderTest.cpp
+ Path.cpp
+ raw_ostream_test.cpp
+ RegexTest.cpp
+ SwapByteOrderTest.cpp
+ TimeValue.cpp
+ TypeBuilderTest.cpp
+ ValueHandleTest.cpp
+ YAMLParserTest.cpp
+ )